Problem:
When uploading test results to TestOps, you may encounter the following error:
[ERROR] Failed to upload batch (188375582). Reason: failed sending upload request: sess: 20839, err: POST : 0
Steps to Resolve
Enable debug logging mode for the upload command.
Detailed instructions: https://docs.qameta.io/allure-testops/ecosystem/allurectl/#test-result-upload-debuggingRetry the upload and carefully review the detailed error messages.
Example (for cloud users mostly)
With debug mode enabled, you might see an error like this:
[ERROR] Failed to upload batch (188375582). Reason: failed sending upload request: sess: 20839, err: POST : 0
<html>
<head><title>502 Bad Gateway</title></head>
<body>
<center><h1>502 Bad Gateway</h1></center>
<hr><center>cloudflare</center>
</body>
</html>
Root Cause
The most common cause of this error is that the uploaded batch size exceeds the allowed limit.
Uploading test results larger than 100 MB will be blocked due to restrictions on our Cloudflare, which can not be altered from our side
Recommendations
Split your test results into smaller batches.
Do not upload large video files.
Example (for on-premise users mostly)
[ERROR] Failed to upload batch (1149871). Reason: failed sending upload request: sess: 1877, err: POST : 0
<html>
<head><title>413 Request Entity Too Large</title></head>
<body>
<center><h1>413 Request Entity Too Large</h1></center>
<hr><center>nginx</center>
</body>
</html>
Root Cause
This is essentially the same error indicating the same problem, but it occurs on the clients reverse proxy side.
Solution:
Please refer to this documentation block: https://docs.qameta.io/allure-testops/configuration/network/#reverse-proxy-parameters
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article